summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorMarco Felsch <m.felsch@pengutronix.de>2019-03-13 11:03:18 +0100
committerMarco Felsch <m.felsch@pengutronix.de>2019-03-13 14:47:45 +0100
commit734ac9ec5180ddf5636fccf702ca7b3482f45ec9 (patch)
treee9f28d3a4894e8c4a53c414b0ed2475ce14ef91b /tests/meson.build
parent982445fe1c234b1ef5173556a73f659946c1a288 (diff)
downloadpango-734ac9ec5180ddf5636fccf702ca7b3482f45ec9.tar.gz
tests: fix build dependency
In case of cairo is found but without png support this test will fail during linking becuase the 'cairo_surface_write_to_png' is undefined. Signed-off-by: Marco Felsch <m.felsch@pengutronix.de>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index bceb9093..6a74e099 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -35,12 +35,17 @@ if cairo_dep.found()
test_cflags += '-DHAVE_CAIRO'
tests += [
[ 'testiter', [ 'testiter.c' ], [ libpangocairo_dep ] ],
- [ 'test-pangocairo-threads', [ 'test-pangocairo-threads.c' ], [ libpangocairo_dep, cairo_dep ] ],
[ 'markup-parse', [ 'markup-parse.c' ], [ libpangocairo_dep ] ],
[ 'test-layout', [ 'test-layout.c', 'test-common.c' ], [ libpangocairo_dep ] ],
[ 'test-font', [ 'test-font.c' ], [ libpangocairo_dep ] ],
[ 'testattributes', [ 'testattributes.c', 'test-common.c' ], [ libpangocairo_dep ] ],
]
+
+ if pango_cairo_backends.contains('png')
+ tests += [
+ [ 'test-pangocairo-threads', [ 'test-pangocairo-threads.c' ], [ libpangocairo_dep, cairo_dep ] ],
+ ]
+ endif
endif
installed_test_data = [