summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-11-25 15:33:47 +0000
committerMatthias Clasen <mclasen@redhat.com>2021-11-25 15:33:47 +0000
commitf37d293b9cfcc43def6fe4be0483b898774e5a2f (patch)
treee920196bc79edae865d1365fb89f894385fa86df /tests/meson.build
parent55efd092b0319f2a2697c510eafc2b0b23597d26 (diff)
parent553eac2ba028a87718ca20180cabe78fa3bc0204 (diff)
downloadpango-f37d293b9cfcc43def6fe4be0483b898774e5a2f.tar.gz
Merge branch 'serialization-improvements' into 'main'
Rename the serialize errors See merge request GNOME/pango!520
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build14
1 files changed, 12 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 00741a14..1984ed03 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -44,18 +44,28 @@ if cairo_dep.found()
[ 'testiter', [ 'testiter.c' ], [ libpangocairo_dep ] ],
[ 'test-ellipsize', [ 'test-ellipsize.c' ], [ libpangocairo_dep ] ],
[ 'markup-parse', [ 'markup-parse.c' , 'test-common.c' ], [ libpangocairo_dep ] ],
- [ 'test-layout', [ 'test-layout.c', 'test-common.c' ], [ libpangocairo_dep ] ],
[ 'test-itemize', [ 'test-itemize.c', 'test-common.c' ], [ libpangocairo_dep ] ],
[ 'test-shape', [ 'test-shape.c', 'test-common.c' ], [ libpangocairo_dep ] ],
[ 'test-font', [ 'test-font.c' ], [ libpangocairo_dep ] ],
[ 'testattributes', [ 'testattributes.c', 'test-common.c' ], [ libpangocairo_dep ] ],
- [ 'testmisc', [ 'testmisc.c' ], [ libpangocairo_dep, libpangoft2_dep, glib_dep, harfbuzz_dep ] ],
[ 'cxx-test', [ 'cxx-test.cpp' ], [ libpangocairo_dep, gobject_dep, harfbuzz_dep ] ],
[ 'test-harfbuzz', [ 'test-harfbuzz.c' ], [ libpangocairo_dep, gobject_dep, harfbuzz_dep ] ],
[ 'test-break', [ 'test-break.c', 'test-common.c', 'validate-log-attrs.c' ], [libpangocairo_dep, glib_dep, harfbuzz_dep ] ],
[ 'testserialize', [ 'testserialize.c' ], [ libpangocairo_dep ] ],
]
+ if build_pangoft2
+ tests += [
+ [ 'testmisc', [ 'testmisc.c' ], [ libpangocairo_dep, libpangoft2_dep, glib_dep, harfbuzz_dep ] ],
+ ]
+
+ if host_system != 'darwin'
+ tests += [
+ [ 'test-layout', [ 'test-layout.c', 'test-common.c' ], [ libpangocairo_dep, libpangoft2_dep ] ],
+ ]
+ endif
+ endif
+
if host_system != 'darwin'
tests += [
[ 'testrandom', [ 'testrandom.c' ], [ libpangocairo_dep, gio_dep ] ],