summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-07-10 17:14:39 -0400
committerMatthias Clasen <mclasen@redhat.com>2021-07-10 18:50:07 -0400
commit5d8694fd3085ce6d870d49f96f9cdd07de151f8e (patch)
tree45c021b519e4281f7e814fa0bad2b30879043fbf /tests/meson.build
parent6a28e306a4b4a779aa62f0eab4e2f1c70241345c (diff)
downloadpango-5d8694fd3085ce6d870d49f96f9cdd07de151f8e.tar.gz
tests: Locale handling fixes
The return value of setlocale is only good until the next call. Also, consistently use en_US.UTF-8.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index baf5ad6b..841a78eb 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -16,6 +16,7 @@ test_env = environment()
test_env.set('srcdir', meson.current_source_dir())
test_env.set('G_TEST_SRCDIR', meson.current_source_dir())
test_env.set('G_TEST_BUILDDIR', meson.current_build_dir())
+test_env.set('LC_ALL', 'en_US.UTF-8')
tests = [
[ 'test-bidi' ],