summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-01-24 11:02:21 -0500
committerMarco Trevisan (TreviƱo) <mail@3v1n0.net>2021-05-05 17:17:48 +0200
commit17f0d88e96ae4242c1f835f9eb1e429ae5687770 (patch)
tree93b333ed7cf647de9b5e28f71a21dd22c7d1e687 /tests/meson.build
parentaf62cc0ff88c36a2647eb2fd6d7ad146c41fb304 (diff)
downloadpango-17f0d88e96ae4242c1f835f9eb1e429ae5687770.tar.gz
tests: Add tests for pango_font_describe
Test that round-tripping through pango_font_describe works. This is currently broken for scalable bitmap fonts, such as color Emoji fonts. We skip the test on OS X where we are most likely missing the fonts. (cherry-picked from commit 49b1f80a)
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index c0cd0e72..4b0d4182 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -8,6 +8,8 @@ endif
if host_system == 'windows'
test_cflags += '-DHAVE_WIN32'
+elif host_system == 'darwin'
+ test_cflags += '-DHAVE_CARBON'
endif
test_env = [