summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-03-04 13:17:01 +0000
committerRoss Burton <ross.burton@intel.com>2019-03-25 14:15:52 +0000
commitfa1c76a58ba9f9ba44462cad877c21db1eeaedd2 (patch)
treeb8475e0f2d0e0014b9128b562381df4707b62575 /tests/meson.build
parent806bcfb8f2e854740180ea5a39ae7ebdd58c5906 (diff)
downloadpango-fa1c76a58ba9f9ba44462cad877c21db1eeaedd2.tar.gz
markup-parse: don't duplicate code
Use the functions in test-common.c instead of replicating them.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 6a74e099..36fb4f16 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -35,7 +35,7 @@ if cairo_dep.found()
test_cflags += '-DHAVE_CAIRO'
tests += [
[ 'testiter', [ 'testiter.c' ], [ libpangocairo_dep ] ],
- [ 'markup-parse', [ 'markup-parse.c' ], [ libpangocairo_dep ] ],
+ [ 'markup-parse', [ 'markup-parse.c' , 'test-common.c' ], [ libpangocairo_dep ] ],
[ 'test-layout', [ 'test-layout.c', 'test-common.c' ], [ libpangocairo_dep ] ],
[ 'test-font', [ 'test-font.c' ], [ libpangocairo_dep ] ],
[ 'testattributes', [ 'testattributes.c', 'test-common.c' ], [ libpangocairo_dep ] ],