summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-11-13 18:33:00 -0500
committerMatthias Clasen <mclasen@redhat.com>2021-11-17 00:28:07 -0500
commitc58dfbfa2f49aab45b9a26b782a7c35db3bae110 (patch)
tree61c5396b320e1a33355583378698cf81587c0e93 /tests/meson.build
parent9278c4f0c59b550f9d4ff10219d8e6242baa081f (diff)
downloadpango-c58dfbfa2f49aab45b9a26b782a7c35db3bae110.tar.gz
Add pango_attr_list_to/from_string
Add an api to serialize PangoAttrList. This will be useful in testing and debugging.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index b5eda3e7..00741a14 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -53,6 +53,7 @@ if cairo_dep.found()
[ 'cxx-test', [ 'cxx-test.cpp' ], [ libpangocairo_dep, gobject_dep, harfbuzz_dep ] ],
[ 'test-harfbuzz', [ 'test-harfbuzz.c' ], [ libpangocairo_dep, gobject_dep, harfbuzz_dep ] ],
[ 'test-break', [ 'test-break.c', 'test-common.c', 'validate-log-attrs.c' ], [libpangocairo_dep, glib_dep, harfbuzz_dep ] ],
+ [ 'testserialize', [ 'testserialize.c' ], [ libpangocairo_dep ] ],
]
if host_system != 'darwin'