summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-11-17 05:16:31 +0000
committerMatthias Clasen <mclasen@redhat.com>2021-11-17 05:16:31 +0000
commit9278c4f0c59b550f9d4ff10219d8e6242baa081f (patch)
treeedd26689b8152e5c924c69c5bbb77d4f1409c2dd /tests/meson.build
parent7c3378594b362ec744e7f96e889b45775d13ee26 (diff)
parent82cea295cf3ad21260b35be2ef2aaa30325d272a (diff)
downloadpango-9278c4f0c59b550f9d4ff10219d8e6242baa081f.tar.gz
Merge branch 'rewrite-line-breaking' into 'main'
Rewrite process_item See merge request GNOME/pango!509
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 90bb94ba..b5eda3e7 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -52,9 +52,15 @@ if cairo_dep.found()
[ 'testmisc', [ 'testmisc.c' ], [ libpangocairo_dep, libpangoft2_dep, glib_dep, harfbuzz_dep ] ],
[ 'cxx-test', [ 'cxx-test.cpp' ], [ libpangocairo_dep, gobject_dep, harfbuzz_dep ] ],
[ 'test-harfbuzz', [ 'test-harfbuzz.c' ], [ libpangocairo_dep, gobject_dep, harfbuzz_dep ] ],
- [ 'test-break', [ 'test-break.c', 'test-common.c', 'validate-log-attrs.c' ], [libpangocairo_dep, glib_dep, harfbuzz_dep ] ]
+ [ 'test-break', [ 'test-break.c', 'test-common.c', 'validate-log-attrs.c' ], [libpangocairo_dep, glib_dep, harfbuzz_dep ] ],
]
+ if host_system != 'darwin'
+ tests += [
+ [ 'testrandom', [ 'testrandom.c' ], [ libpangocairo_dep, gio_dep ] ],
+ ]
+ endif
+
if pango_cairo_backends.contains('png')
tests += [
[ 'test-pangocairo-threads', [ 'test-pangocairo-threads.c' ], [ libpangocairo_dep, cairo_dep ] ],