summaryrefslogtreecommitdiff
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2018-07-08 15:50:34 +0200
committerBehdad Esfahbod <behdad@behdad.org>2018-07-08 15:50:34 +0200
commit0727ba98a52823deb44550c2977bf9bffbff3765 (patch)
tree39e2663b8fd6bed65e90a61785d916731efe7a1a /utils/Makefile.am
parent0b785d94d3d8aa7f7fe76ac7851d088fc9541952 (diff)
downloadpango-0727ba98a52823deb44550c2977bf9bffbff3765.tar.gz
[utils] Add pango-list commandline tool
My main interest is performance of font listing API. Figured I can just make a tool out of it. Output format to be improved.
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index b432e50f..97c83413 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -40,6 +40,17 @@ INCLUDES = \
#########################################################
bin_PROGRAMS = pango-view
+
+if HAVE_CAIRO
+bin_PROGRAMS += pango-list
+pango_list_SOURCES = pango-list.c
+pango_list_LDADD = \
+ ../pango/libpangocairo-$(PANGO_API_VERSION).la \
+ ../pango/libpango-$(PANGO_API_VERSION).la \
+ $(GLIB_LIBS)
+endif
+
+
pango_view_SOURCES = \
viewer-render.h \
viewer-render.c \