summaryrefslogtreecommitdiff
path: root/utils/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-05-23 12:30:43 -0400
committerMatthias Clasen <mclasen@redhat.com>2021-05-23 12:30:43 -0400
commit5df00b86e178c1c66049f1b482451df53e656997 (patch)
tree00b76cb44158b42c904893a0df7f55909c56f4c6 /utils/meson.build
parent2f07e562fc1fe370d3c7d9ce70158480a33d3a0a (diff)
downloadpango-5df00b86e178c1c66049f1b482451df53e656997.tar.gz
pango-segmentation: Fixes
Only build pango-segmentation if we have cairo. And add --version here too.
Diffstat (limited to 'utils/meson.build')
-rw-r--r--utils/meson.build21
1 files changed, 17 insertions, 4 deletions
diff --git a/utils/meson.build b/utils/meson.build
index 74d8668b..6d06dbec 100644
--- a/utils/meson.build
+++ b/utils/meson.build
@@ -79,11 +79,24 @@ if cairo_dep.found()
'-DPACKAGE_VERSION="@0@"'.format(meson.project_version()),
])
+ pango_segmentation_sources = [
+ 'pango-segmentation.c',
+ ]
+
+ pango_segmentation_deps = [
+ pango_deps,
+ libpango_dep,
+ libpangocairo_dep
+ ]
+
pango_segmentation = executable('pango-segmentation',
- 'pango-segmentation.c',
- dependencies: [ libpango_dep, libpangocairo_dep ],
+ pango_segmentation_sources,
+ dependencies: pango_segmentation_deps,
include_directories: [ root_inc ],
- install: false,
- )
+ install: true,
+ c_args: [
+ '-DPACKAGE_NAME="@0@"'.format(meson.project_name()),
+ '-DPACKAGE_VERSION="@0@"'.format(meson.project_version()),
+ ])
endif