summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 02d9d43a..e26c7506 100644
--- a/configure.in
+++ b/configure.in
@@ -41,11 +41,13 @@ fi
AC_SUBST(REBUILD)
if test x$no_x = xyes ; then
- AC_MSG_ERROR([X development libraries not found])
+ AC_MSG_WARN([X development libraries not found])
+ have_x=false
+else
+ X_LIBS="$X_LIBS -lX11"
+ have_x=true
fi
-
-X_LIBS="$X_LIBS -lX11"
-
+AM_CONDITIONAL(HAVE_X, $have_x)
#
# Find pkg-config