summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 13 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 00b3aa40..1f45c65a 100644
--- a/configure.in
+++ b/configure.in
@@ -599,11 +599,19 @@ fi
AM_CONDITIONAL(ENABLE_MAN, test x$enable_man != xno)
-GLIB_PREFIX="`$PKG_CONFIG --variable=prefix glib-2.0`"
-CAIRO_PREFIX="`pkg-config --variable=prefix cairo`"
-
-AC_SUBST(GLIB_PREFIX)
-AC_SUBST(CAIRO_PREFIX)
+AC_ARG_ENABLE(doc-cross-references,
+ AC_HELP_STRING([--disable-doc-cross-references],
+ [cross reference glib and cairo symbols @<:@default=yes@:>@]),
+ enable_doc_cross_references=$enableval,
+ enable_doc_cross_references=yes)
+
+if test "x$enable_doc_cross_references" != xno ; then
+ GLIB_PREFIX="`$PKG_CONFIG --variable=prefix glib-2.0`"
+ CAIRO_PREFIX="`pkg-config --variable=prefix cairo`"
+ AC_SUBST(GLIB_PREFIX)
+ AC_SUBST(CAIRO_PREFIX)
+fi
+AM_CONDITIONAL(ENABLE_DOC_CROSS_REFERENCES, test x$enable_doc_cross_references != xno)
dnl ********************************************************
dnl * Options to pass to libtool