summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index 07af8d37..3f677f23 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -40,6 +40,11 @@ tmpl_sources = \
content_files = \
pango_markup.sgml
+extra_files = \
+ layout.gif \
+ layout.fig \
+ layout.eps
+
####################################
# Everything below here is generic #
@@ -49,6 +54,7 @@ TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
EXTRA_DIST = \
$(content_files) \
+ $(extra_files) \
$(DOC_MAIN_SGML_FILE) \
$(DOC_MODULE)-decl.txt \
$(DOC_MODULE)-sections.txt \
@@ -127,5 +133,9 @@ dist-hook: dist-check-gtkdoc
-cp $(srcdir)/sgml/*.bottom $(srcdir)/sgml/*.top $(distdir)/sgml
-cp $(srcdir)/html/index.sgml $(distdir)/html
-cp $(srcdir)/html/*.html $(srcdir)/html/*.css $(distdir)/html
+ mkdir $(distdir)/TEXT; \
+ for f in $(srcdir)/TEXT/* ; do \
+ test -f $$f && cp -p $$f $(distdir)/TEXT; \
+ done
.PHONY : html sgml templates scan