summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
new file mode 100644
index 00000000..4356480b
--- /dev/null
+++ b/examples/Makefile.am
@@ -0,0 +1,17 @@
+## Process this file with automake to create Makefile.in.
+
+noinst_PROGRAMS = pango-viewer
+
+INCLUDES = -I$(top_srcdir)/libpango/
+
+pango_viewer_SOURCES = \
+ viewer.c
+pango_viewer_LDADD = ../libpango/libpango.la $(GTK_LIBS) -lfribidi $(UNICODE_LIBS)
+
+all-local: pango.modules
+
+pango.modules:
+ ( cd ../modules && \
+ ../libpango/pango-querymodules `find . -name '*.so'` > ../examples/pango.modules )
+
+EXTRA_DIST=HELLO.utf8 \ No newline at end of file