summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 76df11b1..25febacb 100644
--- a/meson.build
+++ b/meson.build
@@ -83,7 +83,6 @@ elif cc.get_id() == 'gcc' or cc.get_id() == 'clang'
'-Wlogical-op',
'-Wno-uninitialized',
'-Wno-shadow',
- '-Werror=redundant-decls',
'-Werror=implicit',
'-Werror=nonnull',
'-Werror=init-self',
@@ -104,6 +103,8 @@ elif cc.get_id() == 'gcc' or cc.get_id() == 'clang'
if host_system == 'windows'
test_cflags += [ '-mms-bitfields' ]
+ else
+ test_cflags += [ '-Werror=redundant-decls' ]
endif
else
test_cflags = []