summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 9 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 519251f2..d690aec5 100644
--- a/meson.build
+++ b/meson.build
@@ -259,8 +259,10 @@ if harfbuzz_dep.found()
pango_deps += harfbuzz_dep
endif
-fontconfig_dep = dependency('fontconfig', version: fontconfig_req_version, required: false,
- fallback: ['fontconfig', 'fontconfig_dep'])
+# Only use FontConfig fallback when required or requested
+fontconfig_required = (host_system != 'windows' and host_system != 'darwin') or get_option('use_fontconfig')
+
+fontconfig_dep = dependency('fontconfig', version: fontconfig_req_version, required: false)
if fontconfig_dep.found()
fontconfig_pc = 'fontconfig'
else
@@ -274,6 +276,11 @@ else
endif
endif
+if fontconfig_required and not fontconfig_dep.found()
+ fontconfig_dep = dependency('fontconfig', version: fontconfig_req_version,
+ fallback: ['fontconfig', 'fontconfig_dep'])
+endif
+
if fontconfig_dep.found()
pango_deps += fontconfig_dep