summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e3276ad2..9d4a6fe0 100644
--- a/meson.build
+++ b/meson.build
@@ -196,7 +196,7 @@ pango_deps = []
glib_req_version = '>= 2.33.12'
libthai_req_version = '>= 0.1.9'
harfbuzz_req_version = '>= 1.2.3'
-fontconfig_req_version = '>= 2.10.91'
+fontconfig_req_version = '>= 2.11.91'
xft_req_version = '>= 2.0.0'
cairo_req_version = '>= 1.12.10'
@@ -226,6 +226,9 @@ if fontconfig_dep.found()
if cc.has_function('FcWeightFromOpenType', dependencies: fontconfig_dep)
pango_conf.set('HAVE_FCWEIGHTFROMOPENTYPE', 1)
endif
+ if cc.has_function('FcWeightFromOpenTypeDouble', dependencies: fontconfig_dep)
+ pango_conf.set('HAVE_FCWEIGHTFROMOPENTYPEDOUBLE', 1)
+ endif
endif
# The first version of freetype with a pkg-config file is 2.1.5