summaryrefslogtreecommitdiff
path: root/modules/hangul/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hangul/Makefile.am')
-rw-r--r--modules/hangul/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/modules/hangul/Makefile.am b/modules/hangul/Makefile.am
index aa5c7e72..1a29330d 100644
--- a/modules/hangul/Makefile.am
+++ b/modules/hangul/Makefile.am
@@ -1,12 +1,21 @@
## Process this file with automake to create Makefile.in.
+sources = hangul.c
+
+if INCLUDE_HANGUL
+noinst_LTLIBRARIES = libpango-hangul.la
+moddefine = -DMODULE_PREFIX
+else
moduledir = $(libdir)/pango/modules
module_LTLIBRARIES = pango-hangul.la
+endif
-INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/pango/
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/pango/ $(moddefine)
-pango_hangul_la_SOURCES = hangul.c
pango_hangul_la_LDFLAGS = -rpath $(libdir) -export-dynamic -avoid-version -module
+pango_hangul_la_SOURCES = $(sources)
+
+libpango_hangul_la_SOURCES = $(sources)
EXTRA_DIST = \
tables-ksc5601.i \