summaryrefslogtreecommitdiff
path: root/modules/hebrew/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hebrew/Makefile.am')
-rw-r--r--modules/hebrew/Makefile.am40
1 files changed, 9 insertions, 31 deletions
diff --git a/modules/hebrew/Makefile.am b/modules/hebrew/Makefile.am
index f4480151..7f9297d1 100644
--- a/modules/hebrew/Makefile.am
+++ b/modules/hebrew/Makefile.am
@@ -1,8 +1,6 @@
## Process this file with automake to create Makefile.in.
pangolibs = $(top_builddir)/pango/libpango-$(PANGO_API_VERSION).la $(GLIB_LIBS)
-pangoxlibs = $(top_builddir)/pango/libpangox-$(PANGO_API_VERSION).la $(X_LIBS) $(pangolibs)
-pangoxftlibs = $(top_builddir)/pango/libpangoxft-$(PANGO_API_VERSION).la $(XFT_LIBS) $(pangolibs)
pangoft2libs = $(top_builddir)/pango/libpangoft2-$(PANGO_API_VERSION).la $(FREETYPE_LIBS) $(pangolibs)
INCLUDES = \
@@ -20,31 +18,12 @@ noinst_LTLIBRARIES =
common_sources = hebrew-shaper.c hebrew-shaper.h
-if HAVE_XFT
-INCLUDES += $(XFT_CFLAGS)
-if INCLUDE_HEBREW_XFT
-noinst_LTLIBRARIES += libpango-hebrew-xft.la
-else
-module_LTLIBRARIES += pango-hebrew-xft.la
-endif
-endif
-
-hebrew_xft_sources = $(common_sources) hebrew-fc.c
-
-pango_hebrew_xft_la_LDFLAGS = -export-dynamic -avoid-version -module
-pango_hebrew_xft_la_LIBADD = $(pangoxftlibs)
-pango_hebrew_xft_la_SOURCES = $(hebrew_xft_sources)
-pango_hebrew_xft_la_CFLAGS = -DBUILD_XFT
-libpango_hebrew_xft_la_SOURCES = $(hebrew_xft_sources)
-libpango_hebrew_xft_la_CFLAGS = -DBUILD_XFT -DPANGO_MODULE_PREFIX=_pango_hebrew_xft
-
-
if HAVE_FREETYPE
INCLUDES += $(FREETYPE_CFLAGS)
-if INCLUDE_HEBREW_FT2
-noinst_LTLIBRARIES += libpango-hebrew-ft2.la
+if INCLUDE_HEBREW_FC
+noinst_LTLIBRARIES += libpango-hebrew-fc.la
else
-module_LTLIBRARIES += pango-hebrew-ft2.la
+module_LTLIBRARIES += pango-hebrew-fc.la
endif
endif
@@ -52,14 +31,13 @@ if PLATFORM_WIN32
no_undefined = -no-undefined
endif
-hebrew_ft2_sources = $(common_sources) hebrew-fc.c
+hebrew_fc_sources = $(common_sources) hebrew-fc.c
-pango_hebrew_ft2_la_LDFLAGS = -export-dynamic -avoid-version -module $(no_undefined)
-pango_hebrew_ft2_la_LIBADD = $(pangoft2libs)
-pango_hebrew_ft2_la_SOURCES = $(hebrew_ft2_sources)
-pango_hebrew_ft2_la_CFLAGS = -DBUILD_FT2
-libpango_hebrew_ft2_la_SOURCES = $(hebrew_ft2_sources)
-libpango_hebrew_ft2_la_CFLAGS = -DBUILD_FT2 -DPANGO_MODULE_PREFIX=_pango_hebrew_ft2
+pango_hebrew_fc_la_LDFLAGS = -export-dynamic -avoid-version -module $(no_undefined)
+pango_hebrew_fc_la_LIBADD = $(pangoft2libs)
+pango_hebrew_fc_la_SOURCES = $(hebrew_fc_sources)
+libpango_hebrew_fc_la_SOURCES = $(hebrew_fc_sources)
+libpango_hebrew_fc_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_hebrew_fc
included-modules: $(noinst_LTLIBRARIES)