summaryrefslogtreecommitdiff
path: root/modules/khmer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/khmer/Makefile.am')
-rw-r--r--modules/khmer/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/modules/khmer/Makefile.am b/modules/khmer/Makefile.am
new file mode 100644
index 00000000..d9608f3b
--- /dev/null
+++ b/modules/khmer/Makefile.am
@@ -0,0 +1,45 @@
+## Process this file with automake to create Makefile.in.
+
+pangolibs = $(top_builddir)/pango/libpango-$(PANGO_API_VERSION).la $(GLIB_LIBS)
+pangoft2libs = $(top_builddir)/pango/libpangoft2-$(PANGO_API_VERSION).la $(FREETYPE_LIBS) $(pangolibs)
+
+INCLUDES = \
+ -DG_LOG_DOMAIN=\"Pango\" \
+ -DPANGO_ENABLE_ENGINE \
+ -DG_DISABLE_DEPRECATED \
+ $(PANGO_DEBUG_FLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/pango/ \
+ $(GLIB_CFLAGS)
+
+if PLATFORM_WIN32
+no_undefined = -no-undefined
+endif
+
+moduledir = $(libdir)/pango/$(PANGO_MODULE_VERSION)/modules
+module_LTLIBRARIES =
+noinst_LTLIBRARIES =
+
+
+if HAVE_FREETYPE
+INCLUDES += $(FREETYPE_CFLAGS)
+if INCLUDE_KHMER_FC
+noinst_LTLIBRARIES += libpango-khmer-fc.la
+else
+module_LTLIBRARIES += pango-khmer-fc.la
+endif
+endif
+
+fc_sources = \
+ khmer-fc.c
+
+pango_khmer_fc_la_LDFLAGS = -export-dynamic -avoid-version -module $(no_undefined)
+pango_khmer_fc_la_LIBADD = $(pangoft2libs)
+pango_khmer_fc_la_SOURCES = $(fc_sources)
+libpango_khmer_fc_la_SOURCES = $(fc_sources)
+libpango_khmer_fc_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_khmer_fc
+
+
+included-modules: $(noinst_LTLIBRARIES)
+
+.PHONY: included-modules