summaryrefslogtreecommitdiff
path: root/modules/thai/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/thai/Makefile.am')
-rw-r--r--modules/thai/Makefile.am26
1 files changed, 23 insertions, 3 deletions
diff --git a/modules/thai/Makefile.am b/modules/thai/Makefile.am
index 7b66a756..82918faf 100644
--- a/modules/thai/Makefile.am
+++ b/modules/thai/Makefile.am
@@ -24,7 +24,6 @@ if HAVE_X
INCLUDES += $(X_CFLAGS)
if INCLUDE_THAI_X
noinst_LTLIBRARIES += libpango-thai-x.la
-INCLUDES += -DX_MODULE_PREFIX
else
module_LTLIBRARIES += pango-thai-x.la
endif
@@ -36,24 +35,45 @@ pango_thai_x_la_LDFLAGS = -export-dynamic -avoid-version -module
pango_thai_x_la_LIBADD = $(pangoxlibs)
pango_thai_x_la_SOURCES = $(thai_x_sources)
libpango_thai_x_la_SOURCES = $(thai_x_sources)
+libpango_thai_x_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_thai_x
if HAVE_XFT
INCLUDES += $(XFT_CFLAGS)
if INCLUDE_THAI_XFT
noinst_LTLIBRARIES += libpango-thai-xft.la
-INCLUDES += -DXFT_MODULE_PREFIX
else
module_LTLIBRARIES += pango-thai-xft.la
endif
endif
-thai_xft_sources = $(common_sources) thai-xft.c
+thai_xft_sources = $(common_sources) thai-fc.c
pango_thai_xft_la_LDFLAGS = -export-dynamic -avoid-version -module
pango_thai_xft_la_LIBADD = $(pangoxftlibs)
pango_thai_xft_la_SOURCES = $(thai_xft_sources)
+pango_thai_xft_la_CFLAGS = -DBUILD_XFT
libpango_thai_xft_la_SOURCES = $(thai_xft_sources)
+libpango_thai_xft_la_CFLAGS = -DBUILD_XFT -DPANGO_MODULE_PREFIX=_pango_thai_xft
+
+
+if HAVE_FREETYPE
+INCLUDES += $(FREETYPE_CFLAGS)
+if INCLUDE_THAI_FT2
+noinst_LTLIBRARIES += libpango-thai-ft2.la
+else
+module_LTLIBRARIES += pango-thai-ft2.la
+endif
+endif
+
+thai_ft2_sources = $(common_sources) thai-fc.c
+
+pango_thai_ft2_la_LDFLAGS = -export-dynamic -avoid-version -module
+pango_thai_ft2_la_LIBADD = $(pangoft2libs)
+pango_thai_ft2_la_SOURCES = $(thai_ft2_sources)
+pango_thai_ft2_la_CFLAGS = -DBUILD_FT2
+libpango_thai_ft2_la_SOURCES = $(thai_ft2_sources)
+libpango_thai_ft2_la_CFLAGS = -DBUILD_FT2 -DPANGO_MODULE_PREFIX=_pango_thai_ft2
included-modules: $(noinst_LTLIBRARIES)