summaryrefslogtreecommitdiff
path: root/modules/thai/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/thai/Makefile.am')
-rw-r--r--modules/thai/Makefile.am22
1 files changed, 20 insertions, 2 deletions
diff --git a/modules/thai/Makefile.am b/modules/thai/Makefile.am
index 1b401357..40f2315c 100644
--- a/modules/thai/Makefile.am
+++ b/modules/thai/Makefile.am
@@ -1,6 +1,6 @@
include $(top_srcdir)/modules/Module.mk
-common_sources = thai-charprop.c thai-charprop.h thai-shaper.c thai-shaper.h
+shaper_sources = thai-charprop.c thai-charprop.h thai-shaper.c thai-shaper.h
if HAVE_FREETYPE
INCLUDES += $(FREETYPE_CFLAGS)
@@ -13,10 +13,28 @@ endif
endif
endif
-thai_fc_sources = $(common_sources) thai-fc.c thai-ot.c thai-ot.h
+thai_fc_sources = $(shaper_sources) thai-fc.c thai-ot.c thai-ot.h
pango_thai_fc_la_LDFLAGS = -module $(MODULE_LIBTOOL_OPTIONS)
pango_thai_fc_la_LIBADD = $(pangoft2libs)
pango_thai_fc_la_SOURCES = $(thai_fc_sources)
libpango_thai_fc_la_SOURCES = $(thai_fc_sources)
libpango_thai_fc_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_thai_fc
+
+
+if INCLUDE_THAI_LANG
+noinst_LTLIBRARIES += libpango-thai-lang.la
+else
+if DYNAMIC_THAI_LANG
+module_LTLIBRARIES += pango-thai-lang.la
+endif
+endif
+
+lang_sources = \
+ thai-lang.c
+
+pango_thai_lang_la_LDFLAGS = -module $(MODULE_LIBTOOL_OPTIONS)
+pango_thai_lang_la_LIBADD = $(pangolibs) $(LIBTHAI_LIBS)
+pango_thai_lang_la_SOURCES = $(lang_sources)
+libpango_thai_lang_la_SOURCES = $(lang_sources)
+libpango_thai_lang_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_thai_lang $(LIBTHAI_CFLAGS)