summaryrefslogtreecommitdiff
path: root/pango/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pango/Makefile.am')
-rw-r--r--pango/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/pango/Makefile.am b/pango/Makefile.am
new file mode 100644
index 00000000..e134358b
--- /dev/null
+++ b/pango/Makefile.am
@@ -0,0 +1,31 @@
+## Process this file with automake to create Makefile.in.
+
+lib_LTLIBRARIES = libpango.la
+bin_PROGRAMS = pango-querymodules
+
+libpango_la_SOURCES = \
+ break.c \
+ fonts.c \
+ glyphstring.c \
+ pangox.c \
+ itemize.c \
+ mapping.c \
+ modules.c \
+ modules.h \
+ reorder-items.c \
+ shape.c \
+ utils.c \
+ utils.h
+
+# We use the -release flag for now until the API settles
+# down at which point we'll either use the GTK+ versioning
+# scheme or the standard libtool scheme.
+#
+libpango_la_LDFLAGS = -release $(VERSION)
+
+include_HEADERS = pango.h pangox.h
+
+pango_querymodules_SOURCES = \
+ querymodules.c
+pango_querymodules_LDADD = libpango.la $(GTK_LIBS) -lfribidi $(UNICODE_LIBS)
+