summaryrefslogtreecommitdiff
path: root/pango/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'pango/meson.build')
-rw-r--r--pango/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/pango/meson.build b/pango/meson.build
index 738bd36c..b2496373 100644
--- a/pango/meson.build
+++ b/pango/meson.build
@@ -152,11 +152,16 @@ libpango_dep = declare_dependency(
sources: pango_dep_sources,
)
+pango_pkg_requires = ['gobject-2.0']
+if harfbuzz_dep.type_name() == 'pkgconfig'
+ pango_pkg_requires += 'harfbuzz'
+endif
+
pkgconfig.generate(libpango,
name: 'Pango',
description: 'Internationalized text handling',
version: meson.project_version(),
- requires: ['gobject-2.0', 'harfbuzz'],
+ requires: pango_pkg_requires,
filebase: 'pango',
subdirs: pango_api_name,
install_dir: join_paths(pango_libdir, 'pkgconfig'),