summaryrefslogtreecommitdiff
path: root/pango/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'pango/meson.build')
-rw-r--r--pango/meson.build15
1 files changed, 10 insertions, 5 deletions
diff --git a/pango/meson.build b/pango/meson.build
index 99a9e4a6..b2496373 100644
--- a/pango/meson.build
+++ b/pango/meson.build
@@ -152,11 +152,16 @@ libpango_dep = declare_dependency(
sources: pango_dep_sources,
)
+pango_pkg_requires = ['gobject-2.0']
+if harfbuzz_dep.type_name() == 'pkgconfig'
+ pango_pkg_requires += 'harfbuzz'
+endif
+
pkgconfig.generate(libpango,
name: 'Pango',
description: 'Internationalized text handling',
version: meson.project_version(),
- requires: ['gobject-2.0', 'harfbuzz'],
+ requires: pango_pkg_requires,
filebase: 'pango',
subdirs: pango_api_name,
install_dir: join_paths(pango_libdir, 'pkgconfig'),
@@ -237,9 +242,9 @@ if build_pangoft2
nsversion: pango_api_version,
identifier_prefix: 'PangoFc',
symbol_prefix: 'pango_fc',
- export_packages: 'pangoft2',
+ export_packages: 'pangofc',
includes: [ pango_gir[0], 'fontconfig-2.0', ],
- header: 'pango/pangoft2.h',
+ header: 'pango/pangofc-fontmap.h',
install: true,
extra_args: gir_args,
)
@@ -255,9 +260,9 @@ if build_pangoft2
nsversion: pango_api_version,
identifier_prefix: 'PangoOT',
symbol_prefix: 'pango_ot',
- export_packages: 'pangoft2',
+ export_packages: 'pangoot',
includes: [ pangofc_gir[0], 'freetype2-2.0', ],
- header: 'pango/pangoft2.h',
+ header: 'pango/pango-ot.h',
install: true,
extra_args: gir_args,
)