summaryrefslogtreecommitdiff
path: root/pango/opentype/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pango/opentype/Makefile.am')
-rw-r--r--pango/opentype/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/pango/opentype/Makefile.am b/pango/opentype/Makefile.am
index 7c6e0d1d..25b0718f 100644
--- a/pango/opentype/Makefile.am
+++ b/pango/opentype/Makefile.am
@@ -6,6 +6,10 @@ INCLUDES = \
noinst_LTLIBRARIES = libharfbuzz-1.la
MAINSOURCES = \
+ harfbuzz.c
+
+# included from harfbuzz.c
+INCLUDEDSOURCES = \
ftglue.c \
harfbuzz-buffer.c \
harfbuzz-gdef.c \
@@ -13,8 +17,6 @@ MAINSOURCES = \
harfbuzz-gsub.c \
harfbuzz-open.c
-EXTRA_SOURCES = harfbuzz.c
-
PUBLICHEADERS = \
harfbuzz.h \
harfbuzz-buffer.h \
@@ -55,5 +57,4 @@ EXTRA_DIST = \
COPYING.FTL \
COPYING.GPL \
COPYING \
- $(EXTRA_SOURCES)
-
+ $(INCLUDED_SOURCES)