summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6bac8b1a..16bca8a8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,14 +4,18 @@ INCLUDES = -I$(top_srcdir) $(GLIB_CFLAGS)
TESTS=runtests.sh
-noinst_PROGRAMS = dump-boundaries
+noinst_PROGRAMS = gen-all-unicode dump-boundaries
check_PROGRAMS = testboundaries
+gen_all_unicode_SOURCES = gen-all-unicode.c
+
testboundaries_SOURCES = testboundaries.c
dump_boundaries_SOURCES = dump-boundaries.c
+gen_all_unicode_LDADD = $(GLIB_LIBS)
+
testboundaries_LDADD = ../pango/libpango.la
dump_boundaries_LDADD = ../pango/libpango.la
@@ -21,3 +25,7 @@ EXTRA_DIST = \
boundaries.utf8 \
runtests.sh
+all-unicode.txt: gen-all-unicode
+ ./gen-all-unicode > all-unicode.txt
+
+all-local: all-unicode.txt