summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index fa3ed125..2726bbba 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -41,12 +41,12 @@ TESTS_ENVIRONMENT = \
srcdir=$(srcdir) \
PANGO_RC_FILE=./pangorc
-noinst_PROGRAMS = gen-all-unicode dump-boundaries
+noinst_PROGRAMS = gen-all-unicode dump-boundaries
check_PROGRAMS = testboundaries testboundaries_ucd testcolor testscript
if HAVE_CAIRO
-check_PROGRAMS += testiter
+check_PROGRAMS += testiter test-pangocairo-threads
endif
if HAVE_FREETYPE
check_PROGRAMS += test-ot-tags
@@ -64,6 +64,7 @@ testiter_LDADD = $(TEST_PANGOCAIRO_LIBS)
testscript_LDADD = $(TEST_PANGO_LIBS)
test_ot_tags_LDADD = $(TEST_PANGOFT2_LIBS)
dump_boundaries_LDADD = $(TEST_PANGO_LIBS)
+test_pangocairo_threads_LDADD = $(TEST_PANGOCAIRO_LIBS) $(GTHREAD_LIBS)
if HAVE_CXX
check_PROGRAMS += cxx-test