summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build43
1 files changed, 42 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index ccd2541e..3e9d8075 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -22,7 +22,10 @@ tests = [
[ 'testboundaries' ],
[ 'testboundaries_ucd' ],
[ 'testcolor' ],
- [ 'testscript' ]
+ [ 'testscript' ],
+ [ 'testlanguage' ],
+ [ 'testmatrix' ],
+ [ 'testtabs' ],
]
if build_pangoft2
@@ -35,6 +38,7 @@ endif
if cairo_dep.found()
test_cflags += '-DHAVE_CAIRO'
tests += [
+ [ 'testcontext', [ 'testcontext.c' ], [ libpangocairo_dep ] ],
[ 'testiter', [ 'testiter.c' ], [ libpangocairo_dep ] ],
[ 'test-ellipsize', [ 'test-ellipsize.c' ], [ libpangocairo_dep ] ],
[ 'markup-parse', [ 'markup-parse.c' , 'test-common.c' ], [ libpangocairo_dep ] ],
@@ -79,6 +83,39 @@ test_markups_data = [
'markups/fail-3',
'markups/fail-4',
'markups/fail-5',
+ 'markups/fail-6',
+ 'markups/fail-7',
+ 'markups/fail-8',
+ 'markups/fail-9',
+ 'markups/fail-10',
+ 'markups/fail-11',
+ 'markups/fail-12',
+ 'markups/fail-13',
+ 'markups/fail-14',
+ 'markups/fail-15',
+ 'markups/fail-16',
+ 'markups/fail-17',
+ 'markups/fail-19',
+ 'markups/fail-20',
+ 'markups/fail-21',
+ 'markups/fail-22',
+ 'markups/fail-23',
+ 'markups/fail-24',
+ 'markups/fail-25',
+ 'markups/fail-26',
+ 'markups/fail-27',
+ 'markups/fail-28',
+ 'markups/fail-29',
+ 'markups/fail-30',
+ 'markups/fail-31',
+ 'markups/fail-32',
+ 'markups/fail-33',
+ 'markups/fail-34',
+ 'markups/fail-35',
+ 'markups/fail-36',
+ 'markups/fail-37',
+ 'markups/fail-38',
+ 'markups/fail-39',
'markups/valid-1',
'markups/valid-2',
'markups/valid-3',
@@ -94,6 +131,10 @@ test_markups_data = [
'markups/valid-13',
'markups/valid-14',
'markups/valid-15',
+ 'markups/valid-16',
+ 'markups/valid-17',
+ 'markups/valid-18',
+ 'markups/valid-19',
]
test_breaks_data = [