summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build29
1 files changed, 27 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 6357cd8a..b2d2d3e1 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -21,8 +21,8 @@ tests = [
[ 'testboundaries_ucd' ],
[ 'testcolor' ],
[ 'testscript' ],
- [ 'cxx-test', [ 'cxx-test.cpp' ] ],
- [ 'test-break', [ 'test-break.c', 'test-common.c' ] ],
+ [ 'cxx-test', [ 'cxx-test.cpp' ], [ libpangocairo_dep ] ],
+ [ 'test-break', [ 'test-break.c', 'test-common.c' ], [libpangocairo_dep ] ],
]
if build_pangoft2
@@ -38,6 +38,7 @@ if cairo_dep.found()
[ 'testiter', [ 'testiter.c' ], [ libpangocairo_dep ] ],
[ 'markup-parse', [ 'markup-parse.c' , 'test-common.c' ], [ libpangocairo_dep ] ],
[ 'test-layout', [ 'test-layout.c', 'test-common.c' ], [ libpangocairo_dep ] ],
+ [ 'test-itemize', [ 'test-itemize.c', 'test-common.c' ], [ libpangocairo_dep ] ],
[ 'test-font', [ 'test-font.c' ], [ libpangocairo_dep ] ],
[ 'testattributes', [ 'testattributes.c', 'test-common.c' ], [ libpangocairo_dep ] ],
]
@@ -80,6 +81,16 @@ test_markups_data = [
'markups/valid-9',
]
+test_breaks_data = [
+ 'breaks/one',
+ 'breaks/two',
+ 'breaks/three',
+]
+
+test_items_data = [
+ 'itemize/one',
+]
+
installed_test_layouts_data = []
foreach d: test_layouts_data
installed_test_layouts_data += d + '.markup'
@@ -92,6 +103,18 @@ foreach d: test_markups_data
installed_test_markups_data += d + '.expected'
endforeach
+installed_test_breaks_data = []
+foreach d: test_breaks_data
+ installed_test_breaks_data += d + '.break'
+ installed_test_breaks_data += d + '.expected'
+endforeach
+
+installed_test_items_data = []
+foreach d: test_items_data
+ installed_test_items_data += d + '.items'
+ installed_test_items_data += d + '.expected'
+endforeach
+
installed_test_datadir = join_paths(pango_datadir, 'installed-tests', 'pango')
installed_test_bindir = join_paths(pango_libexecdir, 'installed-tests', 'pango')
@@ -99,6 +122,8 @@ if get_option('install-tests')
install_data(installed_test_data, install_dir: installed_test_bindir)
install_data(installed_test_layouts_data, install_dir: join_paths(installed_test_bindir, 'layouts'))
install_data(installed_test_markups_data, install_dir: join_paths(installed_test_bindir, 'markups'))
+ install_data(installed_test_breaks_data, install_dir: join_paths(installed_test_bindir, 'breaks'))
+ install_data(installed_test_items_data, install_dir: join_paths(installed_test_bindir, 'itemize'))
endif
python = import('python3').find_python()