summaryrefslogtreecommitdiff
path: root/trunk/modules/hangul/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/modules/hangul/Makefile.am')
-rw-r--r--trunk/modules/hangul/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/trunk/modules/hangul/Makefile.am b/trunk/modules/hangul/Makefile.am
new file mode 100644
index 00000000..3b3c52fa
--- /dev/null
+++ b/trunk/modules/hangul/Makefile.am
@@ -0,0 +1,24 @@
+include $(top_srcdir)/modules/Module.mk
+
+if HAVE_FREETYPE
+INCLUDES += $(FREETYPE_CFLAGS)
+if INCLUDE_HANGUL_FC
+noinst_LTLIBRARIES += libpango-hangul-fc.la
+else
+if DYNAMIC_HANGUL_FC
+module_LTLIBRARIES += pango-hangul-fc.la
+endif
+endif
+endif
+
+fc_sources = hangul-fc.c hangul-defs.h
+
+pango_hangul_fc_la_LDFLAGS = -module $(MODULE_LIBTOOL_OPTIONS)
+pango_hangul_fc_la_LIBADD = $(pangoft2libs)
+pango_hangul_fc_la_SOURCES = $(fc_sources)
+libpango_hangul_fc_la_SOURCES = $(fc_sources)
+libpango_hangul_fc_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_hangul_fc
+
+
+EXTRA_DIST = \
+ tables-jamos.i