summaryrefslogtreecommitdiff
path: root/trunk/modules/khmer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/modules/khmer/Makefile.am')
-rw-r--r--trunk/modules/khmer/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/trunk/modules/khmer/Makefile.am b/trunk/modules/khmer/Makefile.am
new file mode 100644
index 00000000..c1618c9b
--- /dev/null
+++ b/trunk/modules/khmer/Makefile.am
@@ -0,0 +1,21 @@
+include $(top_srcdir)/modules/Module.mk
+
+if HAVE_FREETYPE
+INCLUDES += $(FREETYPE_CFLAGS)
+if INCLUDE_KHMER_FC
+noinst_LTLIBRARIES += libpango-khmer-fc.la
+else
+if DYNAMIC_KHMER_FC
+module_LTLIBRARIES += pango-khmer-fc.la
+endif
+endif
+endif
+
+fc_sources = \
+ khmer-fc.c
+
+pango_khmer_fc_la_LDFLAGS = -module $(MODULE_LIBTOOL_OPTIONS)
+pango_khmer_fc_la_LIBADD = $(pangoft2libs)
+pango_khmer_fc_la_SOURCES = $(fc_sources)
+libpango_khmer_fc_la_SOURCES = $(fc_sources)
+libpango_khmer_fc_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_khmer_fc