summaryrefslogtreecommitdiff
path: root/utils/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'utils/meson.build')
-rw-r--r--utils/meson.build27
1 files changed, 20 insertions, 7 deletions
diff --git a/utils/meson.build b/utils/meson.build
index 12968ef7..6d06dbec 100644
--- a/utils/meson.build
+++ b/utils/meson.build
@@ -79,11 +79,24 @@ if cairo_dep.found()
'-DPACKAGE_VERSION="@0@"'.format(meson.project_version()),
])
-endif
+ pango_segmentation_sources = [
+ 'pango-segmentation.c',
+ ]
-pango_segmentation = executable('pango-segmentation',
- 'pango-segmentation.c',
- dependencies: [ libpango_dep, libpangocairo_dep ],
- include_directories: [ root_inc ],
- install: false,
- )
+ pango_segmentation_deps = [
+ pango_deps,
+ libpango_dep,
+ libpangocairo_dep
+ ]
+
+ pango_segmentation = executable('pango-segmentation',
+ pango_segmentation_sources,
+ dependencies: pango_segmentation_deps,
+ include_directories: [ root_inc ],
+ install: true,
+ c_args: [
+ '-DPACKAGE_NAME="@0@"'.format(meson.project_name()),
+ '-DPACKAGE_VERSION="@0@"'.format(meson.project_version()),
+ ])
+
+endif