summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2014-09-15 14:05:15 -0700
committerAlex Gaynor <alex.gaynor@gmail.com>2014-09-15 14:05:15 -0700
commit56a4739923a356ff5670b4620139ca55a2f30148 (patch)
tree405e2573eaacc37615607a349773d389078c31fc /setup.py
parentf74c7d76ec2ea9d39a4af6643761b648f81bd266 (diff)
downloadparamiko-56a4739923a356ff5670b4620139ca55a2f30148.tar.gz
Switched everything to use cryptography
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 003a0617..91e9640c 100644
--- a/setup.py
+++ b/setup.py
@@ -24,7 +24,7 @@ connections between python scripts. All major ciphers and hash methods
are supported. SFTP client and server mode are both supported too.
Required packages:
- pyCrypto
+ Cryptography
To install the `in-development version
<https://github.com/paramiko/paramiko/tarball/master#egg=paramiko-dev>`_, use
@@ -41,8 +41,9 @@ try:
from setuptools import setup
kw = {
'install_requires': [
- 'pycrypto >= 2.1, != 2.4',
+ 'cryptography >= 0.5.4',
'ecdsa >= 0.11',
+ 'pyasn1',
],
}
except ImportError: