summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2011-11-10 12:11:24 +0100
committerJim Meyering <meyering@redhat.com>2011-11-10 12:11:24 +0100
commit58dd552fa63b38a4060f7e5001eef666def6d365 (patch)
tree63f8fa360711a4685ab5377bfec94a4305512a73 /Makefile.am
parent794913270ef50380cbf1426412428c5fe38e8a02 (diff)
downloadparted-58dd552fa63b38a4060f7e5001eef666def6d365.tar.gz
maint: "make distcheck" now runs the root-only tests
* Makefile.am (root-check): New overridable variable and rule. (distcheck-hook): Depend on it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3a69832..39c1d01 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,7 +28,15 @@ parted.spec: parted.spec.in
mv $@-tmp $@
MAINTAINERCLEANFILES = parted.spec
-distcheck-hook:
+.PHONY: root-check
+root-check:
+ sudo $(MAKE) check
+
+# Not everyone who runs "make distcheck" will want to or even
+# be able to run the root tests. If you want to skip them,
+# run make like this: "make distcheck root-check="
+root-check ?= root-check
+distcheck-hook: $(root-check)
$(MAKE) my-distcheck
### ABI Checking scripts ###