summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-02-27 18:56:36 +0100
committerJim Meyering <jim@meyering.net>2007-02-27 18:56:36 +0100
commit25d5569313677c66dd850af34a6c6f61b0c7e5a7 (patch)
tree3d6255bd29402d122fa3bc038bc8746e0e82ab02 /Makefile.am
parent7cc9fd767dadcf8bbacd8e6d498781b3113d5721 (diff)
downloadparted-25d5569313677c66dd850af34a6c6f61b0c7e5a7.tar.gz
Normalize the way we handle a generated-and-distributed file, parted.spec.
* Makefile.am (EXTRA_DIST): Add parted.spec. (parted.spec): New rule. (MAINTAINERCLEANFILES): Add parted.spec. * configure.ac (AC_OUTPUT): Remove parted.spec from the list.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am43
1 files changed, 25 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index ae5dd8c..15dacb6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,7 @@ EXTRA_DIST = \
BUGS \
libparted.pc.in \
parted.spec.in \
+ parted.spec \
scripts/data/abi/baseline_symbols.txt \
scripts/extract_symvers
@@ -13,8 +14,13 @@ aclocaldir=$(datadir)/aclocal
pcdir = $(libdir)/pkgconfig
pc_DATA = libparted.pc.in
-dist-hook: parted.spec
- cp parted.spec $(distdir)
+# This is best not done via configure.ac, because automake's
+# make distcheck target does not like auto-generated files
+# being included in the distributed archive.
+parted.spec: parted.spec.in
+ sed 's/@''PACKAGE@/@PACKAGE@/;s/@''VERSION@/@VERSION@/' $< > $@-tmp
+ mv $@-tmp $@
+MAINTAINERCLEANFILES = parted.spec
### ABI Checking scripts ###
@@ -53,19 +59,20 @@ check-abi: baseline_symbols current_symbols.txt
MOSTLYCLEANDIRS = m4
-MAINTAINERCLEANFILES = ABOUT-NLS \
- ChangeLog \
- INSTALL \
- Makefile.in \
- aclocal.m4 \
- compile \
- config.guess \
- config.h.in \
- config.rpath \
- config.sub \
- configure \
- depcomp \
- install-sh \
- ltmain.sh \
- missing \
- mkinstalldirs
+MAINTAINERCLEANFILES += \
+ ABOUT-NLS \
+ ChangeLog \
+ INSTALL \
+ Makefile.in \
+ aclocal.m4 \
+ compile \
+ config.guess \
+ config.h.in \
+ config.rpath \
+ config.sub \
+ configure \
+ depcomp \
+ install-sh \
+ ltmain.sh \
+ missing \
+ mkinstalldirs