summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2007-12-17 21:44:43 +0100
committerJim Meyering <meyering@redhat.com>2007-12-18 12:19:01 +0100
commit87ffa76174079107ca6974bfc6b9bd1d22a9c1b1 (patch)
treec7a485245a12f1bc1431ecf0d126cf3bbdd0793e /Makefile.am
parent1b8238461fc1d700e203bf2f858941632d9499e5 (diff)
downloadparted-87ffa76174079107ca6974bfc6b9bd1d22a9c1b1.tar.gz
Make inter-release --version output more useful.
Now, each unofficial build has a version "number" like 1.8.8.1.19-58dd, which indicates that it is built using the 19th change set (in _some_ repository) following the "v1.8.8.1" tag, and that 58dd is a prefix of the commit SHA1. * configure.ac: Run it to set the version. (PED_MAJOR_VERSION): Derive from $PACKAGE_VERSION. (PED_MINOR_VERSION): Likewise. (PED_MICRO_VERSION): Likewise. Remove the test that would ensure $PACKAGE_VERSION != $PED_VERSION, now that the latter is derived from the former. * Makefile.am (dist-hook): Arrange so that .version appears only in distribution tarballs, never in a checked-out repository. * .gitignore: Add .version here, too. Just in case. * lib/.gitignore: Remove now-generated (by bootstrap) file. * build-aux/.gitignore: Likewise. Ensure that $(VERSION) is up to date for dist-related targets. * GNUmakefile: Arrange to rerun autoconf, if the version reported by git-version-gen doesn't match $(VERSION), but only for dist targets.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1aba177..d5b722a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,3 +72,8 @@ MAINTAINERCLEANFILES += \
INSTALL \
aclocal.m4 \
configure
+
+# Arrange so that .version appears only in distribution tarballs,
+# never in a checked-out repository.
+dist-hook:
+ echo $(VERSION) > $(distdir)/.version