summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-06-17 11:21:17 +0200
committerJim Meyering <meyering@redhat.com>2009-07-24 15:04:45 +0200
commite0189c09d09d219faf02887bf5316f3fb0d87f17 (patch)
tree13457094b29f24d886efd0cc687f60913e60c8c4 /Makefile.am
parent96ac4ff00e244c7bd4afa238d3143f54e9b7e6cb (diff)
downloadparted-e0189c09d09d219faf02887bf5316f3fb0d87f17.tar.gz
build: arrange for "make check" to run the tests four times,
each using a different simulated partition size. First with an explicit size of 1024, then 2048, then 4096, and finally with the default of 512. * Makefile.am (check-other-sector_sizes): New rule. (check): Depend on it. * README-big-sector: Update accordingly. Suggestion from Otavio Salvador.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 1931bf0..3d0ce15 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -62,10 +62,10 @@ new-abi-baseline:
# 'check-abi' to test for changes against that file.
check-abi: baseline_symbols current_symbols.txt
@diff -u ${baseline_file} ./current_symbols.txt 2>&1 \
- | tee libparted.abi-diff
+ | tee libparted.abi-diff
@test `wc -l < libparted.abi-diff` -eq 0 && exit 0 \
- || echo "ABI has changed. Please, update you ABI package version." \
- && exit 1
+ || echo "ABI has changed. Please, update you ABI package version." \
+ && exit 1
MOSTLYCLEANDIRS = m4
@@ -76,6 +76,16 @@ MAINTAINERCLEANFILES += \
aclocal.m4 \
configure
+# Run the regression test suite with different settings,
+# to ensure it works with simulated partition sizes > 512.
+.PHONY: check-other-sector_sizes
+check-other-sector_sizes:
+ PARTED_SECTOR_SIZE=1024 $(MAKE) check-recursive
+ PARTED_SECTOR_SIZE=2048 $(MAKE) check-recursive
+ PARTED_SECTOR_SIZE=4096 $(MAKE) check-recursive
+
+check: check-other-sector_sizes
+
# Arrange so that .tarball-version appears only in the distribution
# tarball, and never in a checked-out repository.
dist-hook: gen-ChangeLog