summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2006-12-04 23:40:54 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2006-12-04 23:40:54 -0200
commitba43cb6ff7bb1d945062e25b94efecb1b84c0c33 (patch)
tree1c7733bcdcb57cc3de7a77fdc79f1cb261d226f4 /configure.ac
parentdc4df69ecac2c693328dba452f4b4e9df9c0d29f (diff)
downloadparted-ba43cb6ff7bb1d945062e25b94efecb1b84c0c33.tar.gz
Add check unittest support and a initial test for a resizing bug.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8200564..5dc4ebc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -432,6 +432,10 @@ AC_CHECK_HEADER([execinfo.h], [
])
])
+dnl check for "check", unit testing library/header
+PKG_CHECK_MODULES([CHECK], [check >= 0.9.4])
+AM_CONDITIONAL(HAVE_CHECK, test "x$CHECK_LIBS" != "x")
+
dnl Checks for typedefs, structures and compiler characteristics.
AC_PROG_LD
@@ -486,6 +490,7 @@ libparted/fs/ntfs/Makefile
libparted/fs/reiserfs/Makefile
libparted/fs/ufs/Makefile
libparted/fs/xfs/Makefile
+libparted/tests/Makefile
parted/Makefile
partprobe/Makefile
doc/Makefile