summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2011-12-03 15:16:16 +0100
committerJim Meyering <meyering@redhat.com>2011-12-03 15:43:36 +0100
commit6f9977208a6a4453f60bc656419787060ceed903 (patch)
tree9f3388584377e7fc801a030a270c89df63838626 /configure.ac
parente2554c4ce2987a9c7f9dfdbce5a5dde5542c0b65 (diff)
downloadparted-6f9977208a6a4453f60bc656419787060ceed903.tar.gz
build: configure.ac: use -Wno-format-nonliteral
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3915ac0..b5f7abf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -210,7 +210,6 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wpadded" # Our structs are not padded
nw="$nw -Wredundant-decls" # openat.h declares e.g., mkdirat
nw="$nw -Wlogical-op" # any use of fwrite provokes this
- nw="$nw -Wformat-nonliteral" # who.c and pinky.c strftime uses
nw="$nw -Wvla" # warnings in gettext.h
nw="$nw -Wnested-externs" # use of XARGMATCH/verify_function__
nw="$nw -Wswitch-enum" # Too many warnings for now
@@ -242,6 +241,7 @@ if test "$gl_gcc_warnings" = yes; then
gl_WARN_ADD([-Wno-pointer-sign]) # Too many warnings for now
gl_WARN_ADD([-Wno-unused-parameter]) # Too many warnings for now
gl_WARN_ADD([-Wno-unused-macros]) # Too many warnings for now
+ gl_WARN_ADD([-Wno-format-nonliteral])
# FIXME: investigate these
gl_WARN_ADD([-Wno-jump-misses-init])