summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2007-03-15 12:53:35 -0400
committerDavid Cantrell <dcantrel@mortise.boston.redhat.com>2007-05-02 14:17:27 -0400
commita251a6ba52a5738590c2a2fe58e1f60ca6ba057c (patch)
tree8ef07ade890c5b434f654de407a0b816597d99d0 /configure.ac
parentef9e76ee4d34903e22966c31433564c08e5cf14f (diff)
downloadparted-a251a6ba52a5738590c2a2fe58e1f60ca6ba057c.tar.gz
Reverted my patch to configure.ac to remove -Wl,--as-needed from LDFLAGS when checking for libreadline.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 92a8e80..313a0f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -308,8 +308,6 @@ dnl NOTE: We need to remove the gl_cv_ignore_unused_libraries flag if we
dnl detected one earlier. libreadline on some platforms (e.g., RHEL and
dnl Fedora) is left with
if test "$with_readline" = yes; then
- OLD_LDFLAGS="$LDFLAGS"
- LDFLAGS="$(echo $LDFLAGS | sed -e 's/-Wl,--as-needed//g' | sed -e 's/-Wl,-z,ignore//g' | sed -e 's/-z\ ignore//g')"
OLD_LIBS="$LIBS"
LIBS="$LIBS $PARTED_LIBS"
AC_CHECK_LIB(readline, readline,
@@ -327,7 +325,6 @@ package as well (which may be called readline-devel or something similar).
$PARTED_LIBS
)
LIBS="$OLD_LIBS"
- LDFLAGS="$OLD_LDFLAGS"
fi
AC_SUBST(PARTED_LIBS)
@@ -463,13 +460,10 @@ dnl NOTE: We need to remove the gl_cv_ignore_unused_libraries flag if we
dnl detected one earlier. libreadline on some platforms (e.g., RHEL and
dnl Fedora) is left with
if test "$with_readline" = yes; then
- OLD_LDFLAGS="$LDFLAGS"
- LDFLAGS="$(echo $LDFLAGS | sed -e 's/-Wl,--as-needed//g' | sed -e 's/-Wl,-z,ignore//g' | sed -e 's/-z\ ignore//g')"
OLD_LIBS="$LIBS"
LIBS="$LIBS $PARTED_LIBS -lreadline"
AC_CHECK_FUNCS(rl_completion_matches)
LIBS="$OLD_LIBS"
- LDFLAGS="$OLD_LDFLAGS"
fi
AC_CHECK_FUNCS(canonicalize_file_name)