summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-10-23 11:07:29 +0200
committerJim Meyering <jim@meyering.net>2012-10-23 11:30:56 +0200
commitd3a81337ff149294b7cf63c45a61ffa24fa542c5 (patch)
treeecc3751cabfa0b908759c4bbba50df38cfff30c9 /configure.ac
parent2ab9f04692e74c8b1daae68f1c22c5723f6c39ef (diff)
downloadparted-d3a81337ff149294b7cf63c45a61ffa24fa542c5.tar.gz
build: default to --enable-gcc-warnings in a git tree
Anyone building from cloned sources can be assumed to have a new enough environment, such that enabling gcc warnings by default will be useful. Tarballs still default to no warnings, and the default can still be overridden with --disable-gcc-warnings. * configure.ac (gl_gcc_warnings): Set default based on environment.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 832fc20..417f325 100644
--- a/configure.ac
+++ b/configure.ac
@@ -187,7 +187,11 @@ AC_ARG_ENABLE([gcc-warnings],
*) AC_MSG_ERROR([bad value $enableval for gcc-warnings option]) ;;
esac
gl_gcc_warnings=$enableval],
- [gl_gcc_warnings=no]
+ [if test -d "$srcdir"/.git; then
+ gl_gcc_warnings=yes
+ else
+ gl_gcc_warnings=no
+ fi]
)
if test "$gl_gcc_warnings" = yes; then