summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorShin'ichiro Kawasaki <kawasaki@juno.dti.ne.jp>2019-06-15 16:00:53 +0900
committerBrian C. Lane <bcl@redhat.com>2019-08-09 11:54:54 -0700
commitf1591110ec071c8b88420dea8ad50c779f64a681 (patch)
treed563c780af7c31f05ddae41e396ed7980e4eeaca /configure.ac
parentf6b51897d0f2b5e149defe4901965d056cb6ebd7 (diff)
downloadparted-f1591110ec071c8b88420dea8ad50c779f64a681.tar.gz
configure.ac: Check ABI against ABI version 2
GCC 8 fails to compile libparted/labels/aix.c with an error: CC aix.lo cc1: error: -Wabi won't warn about anything [-Werror=abi] cc1: note: -Wabi warns about differences from the most up-to-date ABI, which is also used by default cc1: note: use e.g. -Wabi=11 to warn about changes from GCC 7 cc1: all warnings being treated as errors make[4]: *** [Makefile:1250: aix.lo] Error 1 To avoid the build failure, specify ABI version 2 to check ABI change from GCC 4.9. Signed-off-by: Shin'ichiro Kawasaki <kawasaki@juno.dti.ne.jp> Signed-off-by: Brian C. Lane <bcl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7ab056b..df4cda9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,6 +231,7 @@ if test "$gl_gcc_warnings" = yes; then
gl_WARN_ADD([-Wno-unused-parameter]) # Too many warnings for now
gl_WARN_ADD([-Wno-unused-macros]) # Too many warnings for now
gl_WARN_ADD([-Wno-format-nonliteral])
+ gl_WARN_ADD([-Wabi=2]) # Avoid compile failure with GCC8
# FIXME: investigate these
gl_WARN_ADD([-Wno-jump-misses-init])