summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2011-05-17 23:08:42 +0200
committerJim Meyering <meyering@redhat.com>2011-05-27 17:07:46 +0200
commit374cf226c3f4ae42d1166bcb870e9b3c1496631d (patch)
treef81ab716d91527a23a150be005c27db855ac1a4b /configure.ac
parent01be9b6af3d0af63ff453ef6f27813b18811a949 (diff)
downloadparted-374cf226c3f4ae42d1166bcb870e9b3c1496631d.tar.gz
build: remove configure-time options: --disable-fs, --enable-Werror
* configure.ac: Remove support for --enable-fs and --disable-fs. Remove support for --enable-Werror and --disable-Werror. * README: Remove paragraph about --disable-fs and --enable-discovery-only. * libparted/libparted.c: Now that --disable-fs is gone (i.e., ENABLE_FS would be always 1), remove its #ifdefs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 0 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 76ac8a8..ce2b3b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,15 +117,6 @@ if test "$enable_discover_only" = yes \
)
fi
-AC_ARG_ENABLE([fs],
- [ --enable-fs include filesystem support [default=yes]], ,
- enable_fs=yes
-)
-if test "$enable_fs" = yes; then
- AC_DEFINE([ENABLE_FS], [1],
- [Include file system support. i.e. libparted/fs_...])
-fi
-
AC_ARG_ENABLE([debug],
[ --enable-debug compile in assertions [default=yes]], ,
enable_debug=yes
@@ -157,11 +148,6 @@ if test "$enable_pc98" = yes; then
collisions with msdos partition tables])
fi
-AC_ARG_ENABLE([Werror],
- [ --enable-Werror build with gcc -Werror [default=yes]], ,
- enable_Werror=yes
-)
-
AC_ARG_ENABLE([hfs-extract-fs],
[ --enable-hfs-extract-fs Extract special HFS files for debugging [default=no]], ,
enable_hfs_extract_fs=no
@@ -593,12 +579,6 @@ fi
AC_CHECK_FUNCS([canonicalize_file_name])
-# CFLAGS="$CFLAGS -W -Wall -Wno-unused -Wno-switch -Wno-format"
-
-if test "$enable_Werror" = yes; then
- CFLAGS="$CFLAGS -Werror"
-fi
-
DATE=$(date '+%d %b %Y %H:%M')
USER=$(whoami)
HOST=$(hostname)