summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrel@mortise.boston.redhat.com>2006-12-03 18:25:41 -0500
committerDavid Cantrell <dcantrel@mortise.boston.redhat.com>2006-12-03 18:25:41 -0500
commite6012cac9fa1999d2719f01c35df33cef9b92614 (patch)
tree1f50828fe68e4c922e7a1f580443e43aadbff1ce /configure.ac
parent00ab69cc4471643aa422e3bf9a536ac2fff64266 (diff)
downloadparted-e6012cac9fa1999d2719f01c35df33cef9b92614.tar.gz
Added the --enable-selinux switch to the configure script. If set, it adds -lselinux and -lsepol to the list of libraries to link libparted with. Bumped the version number to 1.9.9 since this is the edge branch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 16 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f762aa2..8200564 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,10 +19,10 @@ dnl if backwards compatibility has been broken (eg. functions removed,
dnl function signatures changed),
dnl set PED_BINARY_AGE _and_ PED_INTERFACE_AGE to 0.
PED_MAJOR_VERSION=1
-PED_MINOR_VERSION=8
-PED_MICRO_VERSION=0
-PED_INTERFACE_AGE=0
-PED_BINARY_AGE=0
+PED_MINOR_VERSION=9
+PED_MICRO_VERSION=9
+PED_INTERFACE_AGE=1
+PED_BINARY_AGE=1
PED_VERSION_SUFFIX=
PED_VERSION=$PED_MAJOR_VERSION.$PED_MINOR_VERSION.$PED_MICRO_VERSION$PED_VERSION_SUFFIX
@@ -74,6 +74,11 @@ if test "$enable_device_mapper" = yes; then
AC_DEFINE(ENABLE_DEVICE_MAPPER, 1, [device mapper (libdevmapper) support])
fi
+AC_ARG_ENABLE(selinux,
+ [ --enable-selinux enable SELinux support [default=no]], ,
+ enable_selinux=no
+)
+
AC_ARG_ENABLE(discover-only,
[ --enable-discover-only support only reading/probing [default=no]], ,
enable_discover_only=no
@@ -249,6 +254,13 @@ if test "$enable_device_mapper" = yes; then
fi
AC_SUBST(DM_LIBS)
+dnl Check for SELinux
+SELINUX_LIBS=""
+if test "$enable_selinux" = yes; then
+ SELINUX_LIBS="-lselinux -lsepol"
+fi
+AC_SUBST(SELINUX_LIBS)
+
dnl Check for libreiserfs
REISER_LIBS=""
if test "$enable_dynamic_loading" = no -a "$enable_discover_only" = no; then