summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhillip Susi <psusi@ubuntu.com>2018-05-04 10:12:05 -0400
committerPhillip Susi <psusi@ubuntu.com>2018-05-07 13:30:19 -0400
commitd91acc645ad1204ded41cfecad337bf9c48952f6 (patch)
tree9703fcc708e3503b011453ee54df56e903fb68d5 /configure.ac
parentba5e0451b51c983e40afd123b6e0d3eddb55e610 (diff)
downloadparted-d91acc645ad1204ded41cfecad337bf9c48952f6.tar.gz
Fix make check
Make check failed due to some warnings treated as errors. One was caused by a warning that a function could have the noreturn attribute. It seems that this had previously been disabled but gcc has changed the flag from -Wmissing-noreturn to -Wsuggest-attribute=noreturn. The recently added volser.c test also caused a few warnings when not compiled on s390x because most of the functions were no used, so #if those out as well.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 738c697..056478f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -226,7 +226,7 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wpacked"
nw="$nw -Wmissing-prototypes"
nw="$nw -Wmissing-declarations"
- nw="$nw -Wmissing-noreturn"
+ nw="$nw -Wsuggest-attribute=noreturn"
# things I might fix soon:
nw="$nw -Wfloat-equal" # sort.c, seq.c
nw="$nw -Wmissing-format-attribute" # copy.c