summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3da4a1d..dc837d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,7 +33,7 @@ AM_CONDITIONAL([ENABLE_MERGE], [test "$enableval" != no])
AM_CONDITIONAL([ALPHA_VERSION],
[[echo "$PACKAGE_VERSION" | grep -- "-[0-9a-f][0-9a-f]*\\(-dirty\\)\\?$" >/dev/null]])
-AM_INIT_AUTOMAKE([1.11.1 -Wall -Werror gnu dist-bzip2 dist-xz color-tests parallel-tests])
+AM_INIT_AUTOMAKE([1.11.2 -Wall -Werror gnu dist-bzip2 dist-xz color-tests parallel-tests])
AM_SILENT_RULES([yes])
AC_CONFIG_HEADER([config.h:config.hin])
@@ -44,6 +44,7 @@ gl_EARLY
gl_USE_SYSTEM_EXTENSIONS
AC_HEADER_STDC
gl_INIT
+AM_PROG_AR
AC_ARG_ENABLE([gcc-warnings],
[AS_HELP_STRING([--enable-gcc-warnings],
@@ -84,6 +85,7 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wswitch-default" # Too many warnings for now
nw="$nw -Wstack-protector" # not worth working around
nw="$nw -Wmissing-format-attribute" # not worth working around in patch
+ nw="$nw -Wsuggest-attribute=format" # warns about util.c
# things to fix soon:
nw="$nw -Wshadow"
nw="$nw -Wstrict-overflow"