summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Sanders <jeremy@jeremysanders.net>2014-06-07 09:20:58 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-07-29 02:46:07 +0200
commit92fbe1a0e53ebfc38578ab16d8d0a353550806b3 (patch)
tree21beeafc67cd8d5def9ead98faeb34a4812788bb /configure.ac
parent2ca39b80600b856f2ae10d253e2088f1714508d3 (diff)
downloadpatchelf-92fbe1a0e53ebfc38578ab16d8d0a353550806b3.tar.gz
Use libattr and libacl to copy permissions if available
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bdda1a6..8ca9ad4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,5 +6,13 @@ AM_INIT_AUTOMAKE([-Wall -Werror dist-bzip2 foreign color-tests parallel-tests])
AM_PROG_CC_C_O
AC_PROG_CXX
+AC_CHECK_HEADERS([attr/libattr.h attr/error_context.h])
+AC_SEARCH_LIBS(attr_copy_file, attr)
+AC_CHECK_FUNCS([attr_copy_file])
+
+AC_CHECK_HEADERS([sys/acl.h acl/libacl.h])
+AC_SEARCH_LIBS(perm_copy_file, acl)
+AC_CHECK_FUNCS([perm_copy_file])
+
AC_CONFIG_FILES([Makefile src/Makefile tests/Makefile patchelf.spec])
AC_OUTPUT