diff options
author | Monty Taylor <mordred@inaugust.com> | 2013-06-10 21:55:50 -0700 |
---|---|---|
committer | Monty Taylor <mordred@inaugust.com> | 2013-06-11 08:17:55 -0700 |
commit | fa4f46e39cb74630c8acdb008ea1bef62e5f4014 (patch) | |
tree | b35a68d2914019d119df2f1cb709e620aae504b4 /setup.py | |
parent | 6c91a6f0f0c4ab04f9847622deb34e4ca76cf569 (diff) | |
download | pbr-fa4f46e39cb74630c8acdb008ea1bef62e5f4014.tar.gz |
Remove explicit depend on distribute.0.5.16
Things in the world are moving towards setuptools 0.7, and
there is not a path between distribute and setuptools. Our explicit
dependency on setuptools is causing us to have to write patches to
try to jump through additional hoops to get it to install in the
right contexts.
Fixes bug 1189941
Change-Id: Id7a749c02203100dab52160a551d3548c8a48fd6
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 13 |
1 files changed, 0 insertions, 13 deletions
@@ -14,19 +14,6 @@ # See the License for the specific language governing permissions and # limitations under the License. -import os -import sys - -try: - sys.path += [x for x in os.listdir(".") if x.endswith(".egg")] - import d2to1 # flake8: noqa -except ImportError: - import subprocess - if not subprocess.call( - [sys.executable] + - "-m pip.__init__ install distribute<0.7 d2to1>=0.2.10,<0.3".split() - ): - sys.exit(subprocess.call([sys.executable] + sys.argv)) import setuptools setuptools.setup( |