summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohannes Erdfelt <johannes.erdfelt@rackspace.com>2013-01-16 18:05:50 +0000
committerJohannes Erdfelt <johannes.erdfelt@rackspace.com>2013-01-16 18:05:50 +0000
commit11b1f61cfccacc5efe122c79c40250d6b7bc79b7 (patch)
tree6fe18db5f22f826bfdeb805d21b0cfd783346554 /setup.py
parent918a4304114436085b20a951123fd19394683356 (diff)
downloadpbr-11b1f61cfccacc5efe122c79c40250d6b7bc79b7.tar.gz
Stop using no longer valid -E option for pip
Fixes bug 1100403 Version 1.1 of pip dropped the -E option. It's not necessary anyway since running pip in a correctly setup virtualenv will automatically do the right thing. Change-Id: Ifec9f27b8dc169d594125a0808126abe77ed42e7
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 315ea87..32f093f 100644
--- a/setup.py
+++ b/setup.py
@@ -108,10 +108,9 @@ def parse_dependency_links(requirements_files=['requirements.txt',
def write_requirements():
- venv = os.environ.get('VIRTUAL_ENV', None)
- if venv is not None:
+ if 'VIRTUAL_ENV' in os.environ:
with open("requirements.txt", "w") as req_file:
- output = subprocess.Popen(["pip", "-E", venv, "freeze", "-l"],
+ output = subprocess.Popen(["pip", "freeze", "-l"],
stdout=subprocess.PIPE)
requirements = output.communicate()[0].strip()
req_file.write(requirements)