summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-01-16 18:27:09 -0500
committerMonty Taylor <mordred@inaugust.com>2013-01-16 18:27:09 -0500
commitfd843b2e8beca1f1ca1536e14258d5dfe55fe20c (patch)
treee39f900c5619803074bc024c85a09cccc1d40ac6 /setup.py
parent11b1f61cfccacc5efe122c79c40250d6b7bc79b7 (diff)
downloadpbr-fd843b2e8beca1f1ca1536e14258d5dfe55fe20c.tar.gz
Remove write_requirements
Everyone hated this, so we decided to get rid of it at the last summit. Actually, come to think of it, I think we decied to get rid of it in San Fran. Change-Id: I7d93af1eb98a37ff018730669731a7ee22516279
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 32f093f..087a954 100644
--- a/setup.py
+++ b/setup.py
@@ -107,15 +107,6 @@ def parse_dependency_links(requirements_files=['requirements.txt',
return dependency_links
-def write_requirements():
- if 'VIRTUAL_ENV' in os.environ:
- with open("requirements.txt", "w") as req_file:
- output = subprocess.Popen(["pip", "freeze", "-l"],
- stdout=subprocess.PIPE)
- requirements = output.communicate()[0].strip()
- req_file.write(requirements)
-
-
def _run_shell_command(cmd):
if os.name == 'nt':
output = subprocess.Popen(["cmd.exe", "/C", cmd],